Base |
The base class for options used to export DWG, DXF and DGN format files.

System Object
Autodesk.Revit.DB BaseExportOptions
Autodesk.Revit.DB ACADExportOptions
Autodesk.Revit.DB DGNExportOptions
Autodesk.Revit.DB BaseExportOptions
Autodesk.Revit.DB ACADExportOptions
Autodesk.Revit.DB DGNExportOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BaseExportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | Colors | Export color mode. Default value is ExportColorMode.IndexColors. |
![]() | HatchPatternsFileName | Custom hatch patterns (pat) file name. |
![]() | HideReferencePlane | Whether or not to hide reference planes. Default value is false. |
![]() | HideScopeBox | Whether or not to hide the scope box. Default value is false. |
![]() | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. |
![]() | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. |
![]() | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BaseExportOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetExportFontTable | Gets font table. |
![]() | GetExportLayerTable | Gets the layer table. |
![]() | GetExportLinetypeTable | Gets a copy of the line type table. |
![]() | GetExportPatternTable | Gets a copy of the pattern table. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetExportFontTable | Sets font table to option. |
![]() | SetExportLayerTable | Sets layer table back to option |
![]() | SetExportLinetypeTable | Sets the line type table to use during export. |
![]() | SetExportPatternTable | Sets the pattern table to use during export. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |