CopyPasteOptions Class


Copy Paste Options Class

Settings to control the behavior of a copy-paste operation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CopyPasteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CopyPasteOptions : IDisposable

The CopyPasteOptions type exposes the following members.

Constructors
Name Description
Public method CopyPasteOptions Creates a new instance of a CopyPasteOptions object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CopyPasteOptions
Public method GetDuplicateTypeNamesHandler Returns current duplicate type names handler or if none is set.
Public method SetDuplicateTypeNamesHandler Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Top
See Also