Create Method (Document, String, FluidType)


Fluid Type Create(Document, String, Fluid Type) Method

Creates a new fluid type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FluidType Create(
	Document document,
	string fluidTypeName,
	FluidType basedOnFluidType
)

Parameters

document Document
The document.
fluidTypeName String
The name of new created fluid type.
basedOnFluidType FluidType
The existing fluid type which is based on.

Return Value

FluidType
The newly created fluid type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The new fluid type will be a duplicate of the input type.
See Also