CurveExtents Class


Curve Extents Class

Represents the start and end parameters for a curve segment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CurveExtents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveExtents : IDisposable

The CurveExtents type exposes the following members.

Properties
Name Description
Public property EndParameter The end parameter of the curve extents.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StartParameter The start parameter of the curve extents.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CurveExtents
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also