BuiltInFailures.SubRegionFailures Class


Built In Failures Sub Region Failures Class

Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures SubRegionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class SubRegionFailures

The BuiltInFailures SubRegionFailures type exposes the following members.

Properties
Name Description
Public property Static member CreateSubRegionFailed Create sub-division failed.
Public property Static member NoHostForToposolidSubregion This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
Public property Static member SubDivisionOffsetInvalid Sub-division's offset must be less than the thickness of its type.
Public property Static member SubDivisionPhaseMismatch Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.
Top
See Also