Temporary |
Creates an in-canvas control.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- data InCanvasControlData
- Data to generate in-canvas control appearance.
- ownerViewId ElementId
- The view in which the control appears. It will show in all views if the id is invalidElementId.
Return Value
Int32Unique index of control for future references.

Exception | Condition |
---|---|
ArgumentException | The ownerViewId provided is not an id of a view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Failed to load the image from specified path. |

This method can perform drawing an image (supplied by the caller) as an in-canvas control in the view(s). The control can react on click by invoking a callback defined in [!:Autodesk::Revit::UI::ITemporaryGraphicsHandler::OnClick(TemporaryGraphicsCommandData)] . The caller can use the returned index to update the control (changing image/location), delete and change visibility (hide/unhide) in response to any events later.