BarsOnNormalSide Property


Rebar Shape Driven Accessor Bars On Normal Side Property

Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool BarsOnNormalSide { get; set; }

Property Value

Boolean
True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.
Exceptions
Exception Condition
InapplicableDataException This rebar element represents a single bar (the layout rule is Single).
InvalidOperationException This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
See Also