Multiply Method


Transform Multiply Method

Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform Multiply(
	Transform right
)

Parameters

right Transform
The specified transformation.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception Condition
ArgumentNullException Thrown when the handle of the specified transformation is .
Remarks
The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also