Rebar |
Create a non-spiral shape definition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- doc Document
- type RebarShapeDefinitionByArcType

Exception | Condition |
---|---|
ArgumentException | The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

Replaces RebarShape.NewDefinitionByArc() from prior versions.