MEPModel Class |
Supports all MEP models that are persistent within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPModel type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectorManager | Retrieves the Connector Manager from this MEPModel. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. |
![]() | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. |

Reference

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Autodesk.Revit.DB.Electrical LightingDevice
Autodesk.Revit.DB.Electrical LightingFixture
Autodesk.Revit.DB.Mechanical MechanicalEquipment
Autodesk.Revit.DB.Mechanical MechanicalFitting
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Autodesk.Revit.DB.Electrical LightingDevice
Autodesk.Revit.DB.Electrical LightingFixture
Autodesk.Revit.DB.Mechanical MechanicalEquipment
Autodesk.Revit.DB.Mechanical MechanicalFitting