Print Method (Boolean)


View Print(Boolean) Method

Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Print(
	bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.
Exceptions
Exception Condition
InvalidOperationException Thrown when the view cannot be printed.
See Also