AddSortGroupField Method


Schedule Definition Add Sort Group Field Method

Adds a new sorting/grouping field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddSortGroupField(
	ScheduleSortGroupField sortGroupField
)

Parameters

sortGroupField ScheduleSortGroupField
The sorting/grouping field to add.
Exceptions
Exception Condition
ArgumentException The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException A non-optional argument was null
InvalidOperationException The resulting sorting/grouping field count would be greater than 4.
See Also