Rebar |
Sets the bar in this rebar set to be hidden or unhidden in the given view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | This rebar cannot have a presentation mode applied for view, as the view is not valid for rebar presentation, or the orientation of the view matches the normal direction of the rebar element. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | barIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |
InapplicableDataException | This rebar element represents a single bar (the layout rule is Single). |

Individual bars of a rebar set can be hidden in a view only if the presentation mode is RebarPresentationMode.Select. If that is not the presentation mode assigned for this set in the view, this method will also change it.