Fabric |
Creates a new instance of a single flat Fabric Sheet element within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FabricSheet Create(
Document document,
Element hostElement,
ElementId fabricSheetTypeId
)
Parameters
- document Document
- The document in which the fabric sheet is to be created.
- hostElement Element
- The element that will host the FabricSheet. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
- fabricSheetTypeId ElementId
- The id of the FabricSheetType.
Return Value
FabricSheetThe newly created single Fabric Sheet instance.

Exception | Condition |
---|---|
ArgumentException | The element hostElement was not found in the given document. -or- The host Element is not a valid host for Fabric Sheet. -or- fabricSheetTypeId should refer to an FabricSheetType element. |
ArgumentNullException | A non-optional argument was null |