GeometryObject Class


Geometry Object Class

The common base class for all geometric primitives.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GeometryObject : APIObject

The GeometryObject type exposes the following members.

Properties
Name Description
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
Public property Visibility The visibility.
Top
Methods
Name Description
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Overrides Object GetHashCode )
Top
Operators
Name Description
Public operator Static member Equality(GeometryObject, GeometryObject) Determines whether two GeometryObjects are the same.
Public operator Static member Inequality(GeometryObject, GeometryObject) Determines whether two GeometryObjects are different.
Top
See Also
Inheritance Hierarchy