Name Property


Element Name Property

A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual string Name { get; set; }

Property Value

String
Exceptions
Exception Condition
InvalidOperationException Thrown when the name of the element cannot be changed.
ArgumentException Thrown when the element requires a unique name and a non-unique name is set.
Remarks
The Name property is a human readable name for the element, such as Wall.
See Also