DuplicateConstruction Method


MEPSpace Construction Duplicate Construction Method

Create a new construction for Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPBuildingConstruction DuplicateConstruction(
	MEPBuildingConstruction pCurrentConstruction,
	string pName
)

Parameters

pCurrentConstruction MEPBuildingConstruction
The existing construction to be duplicated.
pName String
The name of the new construction.

Return Value

MEPBuildingConstruction
Remarks
If the name is same with the existing one, an exception will be thrown.
See Also