StairsComponentConnection Class


Stairs Component Connection Class

Represents information about a connection among stairs components(run to landing).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture StairsComponentConnection

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StairsComponentConnection : IDisposable

The StairsComponentConnection type exposes the following members.

Properties
Name Description
Public property ConnectionType The connection type of the connected stairs component.
Public property ElementId The element Id of connected stairs component in the stairs connection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PeerConnectionType The connection type of the peer connected stairs component.
Public property PeerElementId The element Id of peer connected stairs component in the stairs connection.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the StairsComponentConnection
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also