LinkVisibilityType Property


Revit Link Graphics Settings Link Visibility Type Property

The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView , then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LinkVisibility LinkVisibilityType { get; set; }

Property Value

LinkVisibility
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also