ApplicationDataId Property


Direct Shape Application Data Id Property

A text string that identifies the data to the creating application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string ApplicationDataId { get; set; }

Property Value

String
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
The intended use is to enable the creating application to identify the native data that was the source of this DirectShape. However, the creating application may use any text string as appropriate for its purposes, or leave this property unset.
See Also