GetExternalFileReference Method


Element Get External File Reference Method

Gets information pertaining to the external file referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternalFileReference GetExternalFileReference()

Return Value

ExternalFileReference
An object containing path and type information for the external file referenced by the element.
Exceptions
Exception Condition
InvalidOperationException This Element does not represent an external file.
See Also