IsTransparentPass Method


Draw Context Is Transparent Pass Method

Determines whether the current rendering pass is for transparent objects.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsTransparentPass()

Return Value

Boolean
True when the server should be submitting transparent objects for rendering, false otherwise.
Exceptions
Exception Condition
InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
Remarks

Opaque and transparent geometry should be submitted for rendering separately. See UseInTransparentPass(View) .

See Also