DWFExportOptions Class


DWFExport Options Class

DWF Export options.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DWFExportOptions : CADExportOptions

The DWFExportOptions type exposes the following members.

Constructors
Name Description
Public method DWFExportOptions Default constructor. Sets all options to their default values.
Top
Properties
Name Description
Public property CropBoxVisible Whether to export crop box.
Public property ExportingAreas Whether to also export areas and rooms' geometry.
Public property ExportObjectData Whether to include properties associated with elements.
Public property ExportOnlyViewId Only export the specified view.
Public property ExportTexture Whether to export texture.
Public property ImageFormat Controls the compression level of images embedded.
Public property ImageQuality Image quality level when compressed raster format(JPEG) is used.
Public property MergedViews Whether to merge all views in one file.
Public property PaperFormat Standard paper format.
Public property PortraitLayout Paper orientation - Portrait/Landscape.
Public property StopOnError Whether export process should stop when a view fails to export.
Top
Methods
Name Description
Top
See Also