CurveLoopsProfile Class


Curve Loops Profile Class

Represents a curve loop based profile for sweep or swept blend elements.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveLoopsProfile : SweepProfile

The CurveLoopsProfile type exposes the following members.

Properties
Name Description
Public property Profile Returns the curve loops of the profile.
Top
Methods
Name Description
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also