Panel |
Creates a new instance of a panel schedule template.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PanelScheduleTemplate Create(
Document document,
PanelScheduleType type,
PanelConfiguration config,
string strName
)
Parameters
- document Document
- The document where the element will be created and added.
- type PanelScheduleType
- The panel schedule type.
- config PanelConfiguration
- The panel configuration type.
- strName String
- The name of the panel schedule template to be created.
Return Value
PanelScheduleTemplateThe newly created panel schedule template element.

Exception | Condition |
---|---|
ArgumentException | The type is not valid for this element. -or- The config is not valid for panel schedule type type of this template. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

If the given name has already been used by existing panel schedule templates, a unique name will be used for the newly created template.