Area |
Creates a new hosted area load within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AreaLoad Create(
Document document,
ElementId hostElemId,
XYZ forceVector,
AreaLoadType symbol
)
Parameters
- document Document
- Document to which new area load will be added.
- hostElemId ElementId
- The analytical surface host element id for the area Load.
- forceVector XYZ
- The force vector applied to the 1st reference point of the area load.
- symbol AreaLoadType
- The symbol of the AreaLoad. Set to use default type.
Return Value
AreaLoadIf successful, returns an object of the newly created AreaLoad. is returned if the operation fails.

Exception | Condition |
---|---|
ArgumentException | The element hostElemId does not exist in the document -or- hostElemId is not permitted for this type of load. -or- Thrown when force vector is equal zero. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Thrown if type could not be set for newly created area load. |