VertexFormatBits Enumeration


Vertex Format Bits Enumeration

Vertex format (i.e., the type of data associated with a vertex) represented as a number.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum VertexFormatBits
Members
Member name Value Description
Position 1 Vertex format consisting of a position.
PositionColored 5 Vertex format consisting of a position and a color.
PositionNormal 3 Vertex format consisting of a position and a normal vector.
PositionNormalColored 7 Vertex format consisting of a position, a normal vector, and a color.
Remarks
VertexFormatBits can be used to specify the vertex format in the creation of the following objects:
  1. EffectInstance
  2. VertexFormat
VertexFormatBits is not to be confused with VertexFormat. The latter type of object is associated with low-level graphics functionality and may become invalid. VertexFormat is needed to submit a set of vertex and index buffers for rendering (see DrawContext ).
See Also