CanDeleteElement Method


Document Validation Can Delete Element Method

Indicates if an element can be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanDeleteElement(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document.
elementId ElementId
The id of the element to check.

Return Value

Boolean
True if the element can be deleted, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also