CodeCheckingParameterServiceData Class


Code Checking Parameter Service Data Class

The data needed by code checking server to perform code checking.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure CodeCheckingParameterServiceData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CodeCheckingParameterServiceData : IDisposable

The CodeCheckingParameterServiceData type exposes the following members.

Properties
Name Description
Public property Document The current document.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CodeCheckingParameterServiceData
Public method GetCurrentElements Returns the list of Ids of the current elements.
Top
See Also