RibbonItemData Class


Ribbon Item Data Class

Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonItemData : ItemData

The RibbonItemData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData )
Public property LongDescription Long description of the command tooltip
Public property Name The internal name of the item.
(Inherited from ItemData )
Public property ToolTip The tooltip of item.
(Inherited from ItemData )
Public property ToolTipImage The image to show as a part of the button extended tooltip
Top
Methods
Name Description
Public method Dispose
(Inherited from ItemData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetContextualHelp Gets the contextual help bound with this control.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetContextualHelp Sets the contextual help bound with this button data.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also
Inheritance Hierarchy