FabricWireItem Class


Fabric Wire Item Class

Provides implementation for FabricWires stored in a Custom Fabric Sheet
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure FabricWireItem

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricWireItem : IDisposable

The FabricWireItem type exposes the following members.

Properties
Name Description
Public property Distance Distance to the next fabric wire item Can be 0 to be used with offset along wire.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OffsetAlongWire Offset along wire direction Wire distance should be 0 if we want to be along the same wire
Public property WireLength Wire length for this wire item
Public property WireType The wire type of this wire item
Top
Methods
Name Description
Public method Static member Create Creates a new instance of a single Fabric wire.
Public method Dispose Releases all resources used by the FabricWireItem
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also