GetLapLengthMultiplier Method


Rebar Splice Type Utils Get Lap Length Multiplier Method

Gets the lap length multiplier value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static double GetLapLengthMultiplier(
	Document document,
	ElementId rebarSpliceTypeId
)

Parameters

document Document
The document.
rebarSpliceTypeId ElementId
The Rebar Splice Type id.

Return Value

Double
Returns the lap length multiplier value.
Exceptions
Exception Condition
ArgumentException The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException A non-optional argument was null
See Also