Toposolid
Is
|
Identifies if the setting for stability of Boolean operations for Toposolid elements is enabled or disabled.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- document Document
- The document.
Return Value
BooleanTrue means enable cut void stability setting, otherwise disable.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The stability setting increases the chance of cut and void operation success by applying a random shift
(a hyper-random testing action where the computer shifts the cut-void along the x or y axis, starting from the minimum distance).
Enabling this may slightly impact the accuracy of the geometry.
When used, the voided geometry is changed, and will be reported in a warning.
Please note that success cannot be guaranteed for Boolean operations when this setting is enabled.