AlphanumericRevisionSettings Class


Alphanumeric Revision Settings Class

Contains settings that apply to Revisions with the Alphanumeric RevisionNumberType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB AlphanumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AlphanumericRevisionSettings : IDisposable

The AlphanumericRevisionSettings type exposes the following members.

Constructors
Name Description
Public method AlphanumericRevisionSettings Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method AlphanumericRevisionSettings(AlphanumericRevisionSettings) Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method AlphanumericRevisionSettings(IList String , String, String) Initializes a new instance of the AlphanumericRevisionSettings class
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Prefix The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.
Public property Suffix The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AlphanumericRevisionSettings
Public method GetSequence Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method IsEqual Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method IsValid Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method SetSequence
Top
See Also