SetOrientation Method


View 3D Set Orientation Method

Sets the temporary orientation of the View3D. The new orientation is not saved in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetOrientation(
	ViewOrientation3D newViewOrientation3D
)

Parameters

newViewOrientation3D ViewOrientation3D
The new orientation to set.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException View is locked and cannot be reoriented.
See Also