ClipPlane Class


Clip Plane Class

A set of parameters representing a clip plane in DirectContext3D.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D ClipPlane

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ClipPlane : IDisposable

The ClipPlane type exposes the following members.

Constructors
Name Description
Public method ClipPlane Constructs a copy of the clip plane.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Normal The plane's normal vector.
Public property Origin The plane's origin.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ClipPlane
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also