RevitAPIPreDocEventArgs Class


Revit APIPre Doc Event Args Class

The base class used for pre events where the arguments must supply access to the document.
Inheritance Hierarchy
System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
More

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class RevitAPIPreDocEventArgs : RevitAPIPreEventArgs

The RevitAPIPreDocEventArgs type exposes the following members.

Properties
Name Description
Public property Document The document associated with the event.
Top
Methods
Name Description
Top
See Also
Inheritance Hierarchy