IPipe |
Interface class for external servers implementing Pipe plumbing fixture flow calculation.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IPipePlumbingFixtureFlowServer type exposes the following members.

Name | Description | |
---|---|---|
![]() | Calculate | Calculate the pipe plumbing fixture flow. |
![]() | GetHtmlDescription | The method that Revit will invoke to get an HTML formatted description of the server. |
![]() | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server. |

A typical way to use the external server can be:
- Implement a server class that derives from this interface
- Create a new server object and register it with the service, see ExternalServiceRegistry .
- Assign server for the plumbing flow conversion in PipeSettings .