Filtered |
Increments the iterator to the next element id passing the filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
BooleanTrue if there is another available element id passing the filter in this iterator. False if the iterator has completed all available element ids.

Exception | Condition |
---|---|
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion). |