BuiltInFailures.ElementFailures Class


Built In Failures Element Failures Class

Failures about Elements.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ElementFailures

The BuiltInFailures ElementFailures type exposes the following members.

Properties
Name Description
Public property Static member FailedToRemoveElement Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
Public property Static member NotAllowedToRemoveAllElements You cannot removed all the elements from current solution. At least there should be two elements in the solution.
Public property Static member SplitElementHasTagsWithoutLeaders The split element has one or more Tags without Leaders enabled and needs to be checked.
Top
See Also