MinExternalAngleBetweenTriangles Property


Solid Or Shell Tessellation Controls Min External Angle Between Triangles Property

A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double MinExternalAngleBetweenTriangles { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The given value for minExternalAngleBetweenTriangles must be greater than 0 and no more than 30000 feet.
Remarks
A small value yields more smoothly curved triangulated surfaces, usually at the expense of an increase in the number of triangles. Note that this setting has no effect for planar surfaces. This constraint may be approximately enforced.
See Also