SetRodStructureExtension Method


Fabrication Rod Info Set Rod Structure Extension Method

Set the length of the rod's top extension into structure. The rod must be attached to structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetRodStructureExtension(
	int rodIndex,
	double extension
)

Parameters

rodIndex Int32
The rod index.
extension Double
Distance the rod will extend into the structure.

Return Value

Boolean
Returns true if it was successful otherwise false.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The rods do not attached to any structue.
See Also