CreateSketchBased Method


System Zone Element Type Create Sketch Based Method

Creates a new element type for sketch-based system-zone elements and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static SystemZoneElementType CreateSketchBased(
	Document doc,
	string name
)

Parameters

doc Document
The document where the new type is created.
name String
The name of new type.

Return Value

SystemZoneElementType
The newly created system-zone element type.
Exceptions
Exception Condition
ArgumentException name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- This name is already used by an existing system-zone element type in the document.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also