ViewScheduleExportOptions Class


View Schedule Export Options Class

The export options used to export schedule views.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewScheduleExportOptions : IDisposable

The ViewScheduleExportOptions type exposes the following members.

Constructors
Name Description
Public method ViewScheduleExportOptions Constructs a new instance of the ViewScheduleExportOptions class
Public method ViewScheduleExportOptions(ViewScheduleExportOptions) Constructs a new copy of the input ViewScheduleExportOptions object.
Top
Properties
Name Description
Public property ColumnHeaders How to export column headers. Default is MultipleRows.
Public property FieldDelimiter How to delimit fields. Default is Tab.
Public property HeadersFootersBlanks Whether to export group headers, footers, and blank lines. Default is true.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TextQualifier How to qualify text fields. Default is DoubleQuote.
Public property Title Whether or not to export the schedule title. Default is true.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ViewScheduleExportOptions
Top
See Also