SetGetLocalPathForOpenCallback Method


Revit Link Operations Set Get Local Path For Open Callback Method

Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetGetLocalPathForOpenCallback(
	IGetLocalPathForOpenCallback makeLocalCopyForOpen
)

Parameters

makeLocalCopyForOpen IGetLocalPathForOpenCallback
The IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also