Path |
Returns current state of Reveal Obstacles mode for the given view.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- DBView View
- The view to determine current state of Reveal Obstacles mode for.
Return Value
BooleanTrue if Reveal Obstacles mode is ON for the view, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The Path of Travel calculation service is not available |