ExternalServices.BuiltInExternalServices Class


External Services Built In External Services Class

A collection of ids for external services that are managed and used by Revit directly.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalServices BuiltInExternalServices

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class BuiltInExternalServices

The ExternalServices BuiltInExternalServices type exposes the following members.

Properties
Name Description
Public property Static member AlignmentService Autodesk Internal: The service for Infrastructure Alignments
Public property Static member AnalyticalCurrentCalculationService AnalyticalCurrentCalculationService GUID value:{96BBB101-FDDB-4991-BB41-FBC1BE1552BB} The calculation service for Electrical Analytical Distribution System
Public property Static member ATFTranslationService
Public property Static member AXMImporterService The external service which permits registration of an alternate implementation for AXM import.
Public property Static member CloudExternalService The external service which supports get cloud model information from cloud servers such as C4R.
Public property Static member CodeCheckingParameterService The external service supporting view and modification of the structural code checking parameter in analytical elements. To use this service, programmers implement a server class that derives from ICodeCheckingParameterServer .
Public property Static member ConnectionTypeChangedService The external service used to notify when structural connection changed the type.
Public property Static member CustomFieldEditPropertiesService Autodesk Internal: The service for editing properties of a custom field.
Public property Static member CustomFieldService Autodesk Internal: The service for updating the custom fields of a schedule.
Public property Static member DirectContext3DService The external service that provides the facility to draw externally specified geometry in a Revit view in a way that is conceptually similar to a low-level graphics API. To use this service, programmers implement a server class that derives from Autodesk::Revit::DB::DirectContext3D::IDirectContext3DServer.
Public property Static member DuctFittingAndAccessoryPressureDropService The external service Id which permits registration of an alternate implementation for duct fitting and accessory pressure drop calculation. To use this service, programmers implement a server class that derives from IDuctFittingAndAccessoryPressureDropServer .
Public property Static member DuctFittingAndAccessoryPressureDropUIService The external service which permits registration of an alternate implementation for a duct fitting and accessory pressure drop calculation UI. To use this service, programmers implement a server class that derives from IDuctFittingAndAccessoryPressureDropUIServer .
Public property Static member DuctPressureDropService The external service which permits registration of an alternate implementation for duct pressure drop calculation. To use this service, programmers implement a server class that derives from IDuctPressureDropServer .
Public property Static member ElectricalAnalyticalLoadCombinationUIService The UI service which permits registration of an external server for UI managing Electrical Analytical Load Combination.
Public property Static member ElectricalAnalyticalLoadSetUIService The UI service which permits registration of an external server for UI managing Electrical Analytical Load Set.
Public property Static member EntitlementExternalService The external service which supports get entitlement information.
Public property Static member ExternalDataManagerService
Public property Static member ExternalDataTypeService Unique service id.
Public property Static member ExternalParameterService Autodesk Internal: The service for shared parameter selection.
Public property Static member ExternalResourceService The external service which permits registration of an alternate servers for managing external resources such as linked files.
Public property Static member ExternalResourceUIService The external UI service Id which permits registration of an alternate servers for managing error messages which happen at the loading of the references to external resources such as linked files.
Public property Static member ExternalUIService Unique service id.
Public property Static member ForgeSchemaService Autodesk Internal: The service for interacting with the Forge Schema Service.
Public property Static member FramingProfileService The external service responsible for the generation of the fabrication profile.
Public property Static member GenericRepoHelperService Unique service id.
Public property Static member GeometryAugmentationService Autodesk Internal: The service where GeometryAugmentationServers can be registered.
Public property Static member HoleDefinitionService The external service to view and modify hole definition parameters.
Public property Static member IFCEntityTreeUIService The UI service which permits registration of an external server for new UI managing IFCEntity Selection
Public property Static member IFCExporterService The external service which permits registration of an alternate implementation for IFC export.
Public property Static member IFCImporterService The external service which permits registration of an alternate implementation for IFC import.
Public property Static member MacroManagerUIService The UI service which permits registration of an external server for new Macro Manager UI.
Public property Static member MemberForcesService The external service supporting view and modification of the member forces in analytical elements. The service is still under development and cannot be used. It means that no server can be external registered from it yet.
Public property Static member ModelAccessValidationService The external service which validates the access to Revit model such as Revit Cloud model.
Public property Static member ModifyConnectionParametersService The external service to view and modify structural connection parameters.
Public property Static member ModifyConnectionRangesService The external service to view and modify structural connection ranges of applicability.
Public property Static member NavisworksExporterService The external service which supports export of the model to Navisworks.
Public property Static member PathOfTravelCalculationService Autodesk Internal: The service for path of travel calculations
Public property Static member PipeFittingAndAccessoryPressureDropService The external service which permits registration of an alternate implementation for pipe fitting and accessory pressure drop calculation. To use this service, programmers implement a server class that derives from IPipeFittingAndAccessoryPressureDropServer .
Public property Static member PipeFittingAndAccessoryPressureDropUIService The external service which permits registration of an alternate implementation for a pipe fitting and accessory pressure drop calculation UI. To use this service, programmers implement a server class that derives from IPipeFittingAndAccessoryPressureDropUIServer .
Public property Static member PipeFrictionFactorService Pipe friction factor service id
Public property Static member PipePlumbingFixtureFlowService The external service which permits registration of an alternate implementation for pipe fixture flow calculation. To use this service, programmers implement a server class that derives from IPipePlumbingFixtureFlowServer .
Public property Static member PipePressureDropService The external service which permits registration of an alternate implementation for pipe pressure drop calculation. To use this service, programmers implement a server class that derives from IPipePressureDropServer .
Public property Static member RebarSpliceService Autodesk Internal: The service for spliping a rebar.
Public property Static member RebarUpdateService Autodesk Internal: The service for updating rebar freeform elements
Public property Static member RevisionsOnSheetUIService The UI service which permits registration of an external server for new UI managing RevisionsOnSheet selection
Public property Static member SiteInsertService The external service which permits registration of an alternate implementation for Site insert.
Public property Static member SiteLinkerUIService The external UI service which permits registration of an alternate servers for new UI of link topography
Public property Static member SnappingService Autodesk Internal: The service which provides snap points and lines
Public property Static member StructuralSectionsService The external service supporting view and modification of the structural sections shape in structural elements. The service is still under development and cannot be used. It means that no server can be external registered from it yet.
Public property Static member TemporaryGraphicsHandlerService The external service Id which permits registration of an callback handler for temporary graphics objects managed by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] . To use this service, developers implement a server class that derives from [!:Autodesk::Revit::UI::ITemporaryGraphicsHandler] .
Public property Static member ViewSheetSetUIService The UI service which permits registration of an external server for new UI managing ViewSheetSet.
Public property Static member WallPlacementPostProcessingService Autodesk Internal: The service for post processing something after placing a wall
Top
See Also