SolidGlass Class


Solid Glass Class

A static class that provides access to the property names that appear in the SolidGlass visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual SolidGlass

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SolidGlass

The SolidGlass type exposes the following members.

Properties
Name Description
Public property Static member CommonTintColor The property labeled "Tint Color" from the "SolidGlass" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "SolidGlass" schema.
Public property Static member SolidglassBumpAmount The property labeled "Amount" from the "SolidGlass" schema.
Public property Static member SolidglassBumpEnable The property labeled "Type" from the "SolidGlass" schema.
Public property Static member SolidglassBumpMap The property labeled "Image" from the "SolidGlass" schema.
Public property Static member SolidglassColorByObject The property labeled "Custom Color" from the "SolidGlass" schema.
Public property Static member SolidglassGlossiness The property labeled "Roughness" from the "SolidGlass" schema.
Public property Static member SolidglassReflectance The property labeled "Reflectance" from the "SolidGlass" schema.
Public property Static member SolidglassRefractionIor The property labeled "Refraction" from the "SolidGlass" schema.
Public property Static member SolidglassTransmittance The property labeled "Color" from the "SolidGlass" schema.
Public property Static member SolidglassTransmittanceCustomColor The property labeled "Custom Color" from the "SolidGlass" schema.
Top
See Also