GroupLoadOptions Class


Group Load Options Class

A class containing options for loading a group from a file.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GroupLoadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GroupLoadOptions : IDisposable

The GroupLoadOptions type exposes the following members.

Constructors
Name Description
Public method GroupLoadOptions Creates a new instance of a GroupLoadOptions object.
Top
Properties
Name Description
Public property IncludeAttachedDetails True if attached detail groups should be included, false otherwise. The default value is .
Public property IncludeGrids True if grids should be brought in from the input file, false otherwise. The default value is .
Public property IncludeLevels True if levels should be brought in from the input file, false otherwise. The default value is .
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ReplaceDuplicatedGroups If there are groups with the same names in source and destination documents set this property to to replace existing groups, otherwise the operation will be canceled. The default value is .
Top
Methods
Name Description
Public method Dispose Releases all resources used by the GroupLoadOptions
Public method GetDuplicateTypeNamesHandler Returns current duplicate type names handler or if none is set.
Public method SetDuplicateTypeNamesHandler Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Top
See Also