FamilyParameterSet Class


Family Parameter Set Class

A set that contains FamilyParameter objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyParameterSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyParameterSet : APIObject, 
	IEnumerable

The FamilyParameterSet type exposes the following members.

Constructors
Name Description
Public method FamilyParameterSet Initializes a new instance of the FamilyParameterSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of objects that are in the set.
Top
Methods
Name Description
Public method Clear Removes every item from the set, rendering it empty.
Public method Contains
Public method Erase
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also